From: Cornelia Huck <cohuck@redhat.com>
To: Gerd Hoffmann <kraxel@redhat.com>
Cc: "Stefano Stabellini" <sstabellini@kernel.org>,
"Eduardo Habkost" <ehabkost@redhat.com>,
"David Hildenbrand" <david@redhat.com>,
"Richard Henderson" <rth@twiddle.net>,
"Michael S. Tsirkin" <mst@redhat.com>,
qemu-devel@nongnu.org, "Halil Pasic" <pasic@linux.ibm.com>,
"Christian Borntraeger" <borntraeger@de.ibm.com>,
qemu-s390x@nongnu.org, qemu-ppc@nongnu.org,
"Paolo Bonzini" <pbonzini@redhat.com>,
"Anthony Perard" <anthony.perard@citrix.com>,
"Marc-André Lureau" <marcandre.lureau@redhat.com>,
xen-devel@lists.xenproject.org,
"David Gibson" <david@gibson.dropbear.id.au>
Subject: Re: [Qemu-devel] [PATCH 3/3] machine: Use shorter format for GlobalProperty arrays
Date: Tue, 8 Jan 2019 11:20:12 +0100 [thread overview]
Message-ID: <20190108112012.78f3dbb9.cohuck@redhat.com> (raw)
In-Reply-To: <20190108064543.asg63onrb3hpripf@sirius.home.kraxel.org>
On Tue, 8 Jan 2019 07:45:43 +0100
Gerd Hoffmann <kraxel@redhat.com> wrote:
> Hi,
>
> > + { "migration", "decompress-error-check", "off" },
> > + { "hda-audio", "use-timer", "false" },
> > + { "cirrus-vga", "global-vmstate", "true" },
> > + { "VGA", "global-vmstate", "true" },
> > + { "vmware-svga", "global-vmstate", "true" },
> > + { "qxl-vga", "global-vmstate", "true" },
>
> I'd like to have the fields aligned. Especially in cases like this one
> where multiple devices get the same value assigned it makes things more
> readable:
>
> { "migration", "decompress-error-check", "off" },
> { "hda-audio", "use-timer", "false" },
> { "cirrus-vga", "global-vmstate", "true" },
> { "VGA", "global-vmstate", "true" },
> { "vmware-svga", "global-vmstate", "true" },
> { "qxl-vga", "global-vmstate", "true" },
>
> thanks,
> Gerd
>
I'm a bit on the fence here. It does make things more readable (at
least in your example), but I find editing aligned tables a bit
annoying. OTOH, that won't happen often, anyway.
_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xenproject.org
https://lists.xenproject.org/mailman/listinfo/xen-devel
WARNING: multiple messages have this Message-ID (diff)
From: Cornelia Huck <cohuck@redhat.com>
To: Gerd Hoffmann <kraxel@redhat.com>
Cc: "Eduardo Habkost" <ehabkost@redhat.com>,
qemu-devel@nongnu.org, qemu-ppc@nongnu.org,
"Stefano Stabellini" <sstabellini@kernel.org>,
"David Hildenbrand" <david@redhat.com>,
"Halil Pasic" <pasic@linux.ibm.com>,
"Christian Borntraeger" <borntraeger@de.ibm.com>,
qemu-s390x@nongnu.org, "Michael S. Tsirkin" <mst@redhat.com>,
"Marc-André Lureau" <marcandre.lureau@redhat.com>,
"Anthony Perard" <anthony.perard@citrix.com>,
"Paolo Bonzini" <pbonzini@redhat.com>,
"David Gibson" <david@gibson.dropbear.id.au>,
xen-devel@lists.xenproject.org,
"Richard Henderson" <rth@twiddle.net>
Subject: Re: [Qemu-devel] [PATCH 3/3] machine: Use shorter format for GlobalProperty arrays
Date: Tue, 8 Jan 2019 11:20:12 +0100 [thread overview]
Message-ID: <20190108112012.78f3dbb9.cohuck@redhat.com> (raw)
In-Reply-To: <20190108064543.asg63onrb3hpripf@sirius.home.kraxel.org>
On Tue, 8 Jan 2019 07:45:43 +0100
Gerd Hoffmann <kraxel@redhat.com> wrote:
> Hi,
>
> > + { "migration", "decompress-error-check", "off" },
> > + { "hda-audio", "use-timer", "false" },
> > + { "cirrus-vga", "global-vmstate", "true" },
> > + { "VGA", "global-vmstate", "true" },
> > + { "vmware-svga", "global-vmstate", "true" },
> > + { "qxl-vga", "global-vmstate", "true" },
>
> I'd like to have the fields aligned. Especially in cases like this one
> where multiple devices get the same value assigned it makes things more
> readable:
>
> { "migration", "decompress-error-check", "off" },
> { "hda-audio", "use-timer", "false" },
> { "cirrus-vga", "global-vmstate", "true" },
> { "VGA", "global-vmstate", "true" },
> { "vmware-svga", "global-vmstate", "true" },
> { "qxl-vga", "global-vmstate", "true" },
>
> thanks,
> Gerd
>
I'm a bit on the fence here. It does make things more readable (at
least in your example), but I find editing aligned tables a bit
annoying. OTOH, that won't happen often, anyway.
next prev parent reply other threads:[~2019-01-08 10:20 UTC|newest]
Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-01-07 19:30 [PATCH 0/3] machine: Make compat_props arrays shorter and more readable Eduardo Habkost
2019-01-07 19:30 ` [Qemu-devel] " Eduardo Habkost
2019-01-07 19:30 ` [PATCH 1/3] spapr: Eliminate SPAPR_PCI_2_7_MMIO_WIN_SIZE macro Eduardo Habkost
2019-01-07 19:30 ` [Qemu-devel] " Eduardo Habkost
2019-01-07 19:35 ` Marc-André Lureau
2019-01-07 19:35 ` Marc-André Lureau
2019-01-08 0:07 ` David Gibson
2019-01-08 0:07 ` [Qemu-devel] " David Gibson
2019-01-08 9:59 ` Cornelia Huck
2019-01-08 9:59 ` [Qemu-devel] " Cornelia Huck
2019-01-07 19:30 ` [PATCH 2/3] machine: Eliminate unnecessary stringify() usage Eduardo Habkost
2019-01-07 19:30 ` [Qemu-devel] " Eduardo Habkost
2019-01-07 19:34 ` Marc-André Lureau
2019-01-07 19:34 ` Marc-André Lureau
2019-01-08 0:08 ` David Gibson
2019-01-08 0:08 ` [Qemu-devel] " David Gibson
2019-01-08 10:03 ` Cornelia Huck
2019-01-08 10:03 ` [Qemu-devel] " Cornelia Huck
2019-01-08 14:36 ` Philippe Mathieu-Daudé
2019-01-08 14:36 ` Philippe Mathieu-Daudé
2019-01-07 19:30 ` [PATCH 3/3] machine: Use shorter format for GlobalProperty arrays Eduardo Habkost
2019-01-07 19:30 ` [Qemu-devel] " Eduardo Habkost
2019-01-07 19:40 ` Marc-André Lureau
2019-01-07 19:40 ` Marc-André Lureau
2019-01-08 6:45 ` Gerd Hoffmann
2019-01-08 6:45 ` Gerd Hoffmann
2019-01-08 10:20 ` Cornelia Huck [this message]
2019-01-08 10:20 ` Cornelia Huck
2019-01-10 0:43 ` Eduardo Habkost
2019-01-10 0:43 ` Eduardo Habkost
2019-01-08 10:21 ` Cornelia Huck
2019-01-08 10:21 ` [Qemu-devel] " Cornelia Huck
2019-01-08 14:38 ` Philippe Mathieu-Daudé
2019-01-08 14:38 ` Philippe Mathieu-Daudé
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190108112012.78f3dbb9.cohuck@redhat.com \
--to=cohuck@redhat.com \
--cc=anthony.perard@citrix.com \
--cc=borntraeger@de.ibm.com \
--cc=david@gibson.dropbear.id.au \
--cc=david@redhat.com \
--cc=ehabkost@redhat.com \
--cc=kraxel@redhat.com \
--cc=marcandre.lureau@redhat.com \
--cc=mst@redhat.com \
--cc=pasic@linux.ibm.com \
--cc=pbonzini@redhat.com \
--cc=qemu-devel@nongnu.org \
--cc=qemu-ppc@nongnu.org \
--cc=qemu-s390x@nongnu.org \
--cc=rth@twiddle.net \
--cc=sstabellini@kernel.org \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.