All of lore.kernel.org
 help / color / mirror / Atom feed
From: Andrew Jones <ajones@ventanamicro.com>
To: guoren@kernel.org
Cc: wefu@redhat.com, keescook@chromium.org, peterz@infradead.org,
	unicorn_wang@outlook.com, atishp@atishpatra.org,
	chao.wei@sophgo.com, bjorn@rivosinc.com,
	linux-kernel@vger.kernel.org, xiaoguang.xing@sophgo.com,
	conor.dooley@microchip.com, leobras@redhat.com,
	palmer@dabbelt.com, jszhang@kernel.org, paul.walmsley@sifive.com,
	Guo Ren <guoren@linux.alibaba.com>,
	panqinglin2020@iscas.ac.cn, linux-riscv@lists.infradead.org,
	wuwei2016@iscas.ac.cn
Subject: Re: [PATCH V2 1/3] riscv: Add Zicbop instruction definitions & cpufeature
Date: Wed, 3 Jan 2024 20:48:12 +0100	[thread overview]
Message-ID: <20240103-4f92e1f7290975300ecc64ce@orel> (raw)
In-Reply-To: <20231231082955.16516-2-guoren@kernel.org>

On Sun, Dec 31, 2023 at 03:29:51AM -0500, guoren@kernel.org wrote:
...
> +#define CBO_PREFETCH_I(base, offset)				\
> +	INSN_S(OPCODE_OP_IMM, FUNC3(6), __RS2(0),		\
> +	       SIMM12(offset), RS1(base))
> +
> +#define CBO_PREFETCH_R(base, offset)				\
> +	INSN_S(OPCODE_OP_IMM, FUNC3(6), __RS2(1),		\
> +	       SIMM12(offset), RS1(base))
> +
> +#define CBO_PREFETCH_W(base, offset)				\
> +	INSN_S(OPCODE_OP_IMM, FUNC3(6), __RS2(3),		\
> +	       SIMM12(offset), RS1(base))

These should just be named

 PREFETCH_I
 PREFETCH_R
 PREFETCH_W

without the CBO_ prefix. The other CMO instructions we've added have the
CBO_ prefix because their actual instruction names are e.g. cbo.zero,
but the prefix instructions are not named that way.

Thanks,
drew

_______________________________________________
linux-riscv mailing list
linux-riscv@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-riscv

WARNING: multiple messages have this Message-ID (diff)
From: Andrew Jones <ajones@ventanamicro.com>
To: guoren@kernel.org
Cc: paul.walmsley@sifive.com, palmer@dabbelt.com,
	 panqinglin2020@iscas.ac.cn, bjorn@rivosinc.com,
	conor.dooley@microchip.com,  leobras@redhat.com,
	peterz@infradead.org, keescook@chromium.org,
	 wuwei2016@iscas.ac.cn, xiaoguang.xing@sophgo.com,
	chao.wei@sophgo.com,  unicorn_wang@outlook.com, uwu@icenowy.me,
	jszhang@kernel.org, wefu@redhat.com,  atishp@atishpatra.org,
	linux-riscv@lists.infradead.org, linux-kernel@vger.kernel.org,
	 Guo Ren <guoren@linux.alibaba.com>
Subject: Re: [PATCH V2 1/3] riscv: Add Zicbop instruction definitions & cpufeature
Date: Wed, 3 Jan 2024 20:48:12 +0100	[thread overview]
Message-ID: <20240103-4f92e1f7290975300ecc64ce@orel> (raw)
In-Reply-To: <20231231082955.16516-2-guoren@kernel.org>

On Sun, Dec 31, 2023 at 03:29:51AM -0500, guoren@kernel.org wrote:
...
> +#define CBO_PREFETCH_I(base, offset)				\
> +	INSN_S(OPCODE_OP_IMM, FUNC3(6), __RS2(0),		\
> +	       SIMM12(offset), RS1(base))
> +
> +#define CBO_PREFETCH_R(base, offset)				\
> +	INSN_S(OPCODE_OP_IMM, FUNC3(6), __RS2(1),		\
> +	       SIMM12(offset), RS1(base))
> +
> +#define CBO_PREFETCH_W(base, offset)				\
> +	INSN_S(OPCODE_OP_IMM, FUNC3(6), __RS2(3),		\
> +	       SIMM12(offset), RS1(base))

These should just be named

 PREFETCH_I
 PREFETCH_R
 PREFETCH_W

without the CBO_ prefix. The other CMO instructions we've added have the
CBO_ prefix because their actual instruction names are e.g. cbo.zero,
but the prefix instructions are not named that way.

Thanks,
drew

  parent reply	other threads:[~2024-01-03 19:48 UTC|newest]

Thread overview: 84+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-12-31  8:29 [PATCH V2 0/3] riscv: Add Zicbop & prefetchw support guoren
2023-12-31  8:29 ` guoren
2023-12-31  8:29 ` [PATCH V2 1/3] riscv: Add Zicbop instruction definitions & cpufeature guoren
2023-12-31  8:29   ` guoren
2024-01-02 10:32   ` Andrew Jones
2024-01-02 10:32     ` Andrew Jones
2024-01-03  6:13     ` Guo Ren
2024-01-03  6:13       ` Guo Ren
2024-01-03  6:49       ` Andrew Jones
2024-01-03  6:49         ` Andrew Jones
2024-01-03 19:44         ` Andrew Jones
2024-01-03 19:44           ` Andrew Jones
2024-01-03 19:06     ` Leonardo Bras
2024-01-03 19:06       ` Leonardo Bras
2024-01-03  9:31   ` Clément Léger
2024-01-03  9:31     ` Clément Léger
2024-01-03 12:00     ` Andrew Jones
2024-01-03 12:00       ` Andrew Jones
2024-01-11 10:31       ` Clément Léger
2024-01-11 10:31         ` Clément Léger
2024-01-11 10:45         ` Andrew Jones
2024-01-11 10:45           ` Andrew Jones
2024-01-11 10:49           ` Clément Léger
2024-01-11 10:49             ` Clément Léger
2024-01-11 11:12             ` Conor Dooley
2024-01-11 11:12               ` Conor Dooley
2024-01-03 18:52   ` Leonardo Bras
2024-01-03 18:52     ` Leonardo Bras
2024-01-03 19:29     ` Andrew Jones
2024-01-03 19:29       ` Andrew Jones
2024-01-03 20:33       ` Leonardo Bras
2024-01-03 20:33         ` Leonardo Bras
2024-01-04  9:47         ` Andrew Jones
2024-01-04  9:47           ` Andrew Jones
2024-01-04 15:03           ` Leonardo Bras
2024-01-04 15:03             ` Leonardo Bras
2024-01-04 16:40             ` Andrew Jones
2024-01-04 16:40               ` Andrew Jones
2024-01-04 17:43               ` Leonardo Bras
2024-01-04 17:43                 ` Leonardo Bras
2024-01-05 13:24                 ` Andrew Jones
2024-01-05 13:24                   ` Andrew Jones
2024-01-08 14:34                   ` Leonardo Bras
2024-01-08 14:34                     ` Leonardo Bras
2024-01-08 15:24                     ` Andrew Jones
2024-01-08 15:24                       ` Andrew Jones
2024-01-08 16:14                       ` Leonardo Bras
2024-01-08 16:14                         ` Leonardo Bras
2024-01-03 19:48   ` Andrew Jones [this message]
2024-01-03 19:48     ` Andrew Jones
2024-01-03 20:34     ` Leonardo Bras
2024-01-03 20:34       ` Leonardo Bras
2023-12-31  8:29 ` [PATCH V2 2/3] riscv: Add ARCH_HAS_PRETCHW support with Zibop guoren
2023-12-31  8:29   ` guoren
2024-01-01  2:29   ` Guo Ren
2024-01-01  2:29     ` Guo Ren
2024-01-03 19:04     ` Leonardo Bras
2024-01-03 19:04       ` Leonardo Bras
2024-01-02 10:45   ` Andrew Jones
2024-01-02 10:45     ` Andrew Jones
2024-01-03  6:19     ` Guo Ren
2024-01-03  6:19       ` Guo Ren
2024-01-03 19:56       ` Andrew Jones
2024-01-03 19:56         ` Andrew Jones
2024-01-05 13:31     ` Andrew Jones
2024-01-05 13:31       ` Andrew Jones
2023-12-31  8:29 ` [PATCH V2 3/3] riscv: xchg: Prefetch the destination word for sc.w guoren
2023-12-31  8:29   ` guoren
2024-01-02 11:18   ` Andrew Jones
2024-01-02 11:18     ` Andrew Jones
2024-01-03  6:15     ` Guo Ren
2024-01-03  6:15       ` Guo Ren
2024-01-03 19:45       ` Leonardo Bras
2024-01-03 19:45         ` Leonardo Bras
2024-01-04  1:24         ` Guo Ren
2024-01-04  1:24           ` Guo Ren
2024-01-04  3:56           ` Leonardo Bras
2024-01-04  3:56             ` Leonardo Bras
2024-01-04  8:14             ` Guo Ren
2024-01-04  8:14               ` Guo Ren
2024-01-04 14:17               ` Leonardo Bras
2024-01-04 14:17                 ` Leonardo Bras
2024-01-05  1:13                 ` Guo Ren
2024-01-05  1:13                   ` Guo Ren

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20240103-4f92e1f7290975300ecc64ce@orel \
    --to=ajones@ventanamicro.com \
    --cc=atishp@atishpatra.org \
    --cc=bjorn@rivosinc.com \
    --cc=chao.wei@sophgo.com \
    --cc=conor.dooley@microchip.com \
    --cc=guoren@kernel.org \
    --cc=guoren@linux.alibaba.com \
    --cc=jszhang@kernel.org \
    --cc=keescook@chromium.org \
    --cc=leobras@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-riscv@lists.infradead.org \
    --cc=palmer@dabbelt.com \
    --cc=panqinglin2020@iscas.ac.cn \
    --cc=paul.walmsley@sifive.com \
    --cc=peterz@infradead.org \
    --cc=unicorn_wang@outlook.com \
    --cc=wefu@redhat.com \
    --cc=wuwei2016@iscas.ac.cn \
    --cc=xiaoguang.xing@sophgo.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.