From: SJ Park <sj@kernel.org>
Cc: SJ Park <sj@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
damon@lists.linux.dev, linux-kernel@vger.kernel.org,
linux-mm@kvack.org
Subject: [RFC PATCH v1.2 05/19] mm/damon/core: implement damon_probe_hits_wsum()
Date: Thu, 9 Jul 2026 07:05:43 -0700 [thread overview]
Message-ID: <20260709140600.90950-6-sj@kernel.org> (raw)
In-Reply-To: <20260709140600.90950-1-sj@kernel.org>
When damon_probe->weight is set, the weighted sum of probe hits will be
useful. It will be useful for not only the users but also DAMON
internal logics like regions merging. Implement a function for
calculating it.
Signed-off-by: SJ Park <sj@kernel.org>
---
include/linux/damon.h | 2 ++
mm/damon/core.c | 24 ++++++++++++++++++++++++
2 files changed, 26 insertions(+)
diff --git a/include/linux/damon.h b/include/linux/damon.h
index 4e1845ce83870..516fefaf54dcc 100644
--- a/include/linux/damon.h
+++ b/include/linux/damon.h
@@ -1012,6 +1012,8 @@ unsigned int damon_nr_accesses_mvsum(struct damon_region *r,
struct damon_ctx *ctx);
unsigned char damon_probe_hits_mvsum(int probe_idx, struct damon_region *r,
struct damon_ctx *ctx);
+unsigned int damon_probe_hits_wsum(struct damon_region *r, bool last,
+ struct damon_ctx *ctx);
int damon_set_regions(struct damon_target *t, struct damon_addr_range *ranges,
unsigned int nr_ranges, unsigned long min_region_sz);
diff --git a/mm/damon/core.c b/mm/damon/core.c
index 9f6cdd810bd8a..fea97399b5754 100644
--- a/mm/damon/core.c
+++ b/mm/damon/core.c
@@ -393,6 +393,30 @@ static bool damon_is_last_region(struct damon_region *r,
return list_is_last(&r->list, &t->regions_list);
}
+/**
+ * damon_probe_hits_wsum() - Returns probe hits weighted sum of a region.
+ * @r: region to get the weighted sum of.
+ * @last: if the request is for last-window aggregated probe hits.
+ * @ctx: context of &r.
+ *
+ * Return: the weighted sum of probe hits of the region.
+ */
+unsigned int damon_probe_hits_wsum(struct damon_region *r, bool last,
+ struct damon_ctx *ctx)
+{
+ struct damon_probe *probe;
+ unsigned int sum = 0;
+ int i = 0;
+
+ damon_for_each_probe(probe, ctx) {
+ if (last)
+ sum += r->last_probe_hits[i++] * probe->weight;
+ else
+ sum += r->probe_hits[i++] * probe->weight;
+ }
+ return sum;
+}
+
/*
* Check whether a region is intersecting an address range
*
--
2.47.3
next prev parent reply other threads:[~2026-07-09 14:06 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-09 14:05 [RFC PATCH v1.2 00/19] mm/damon: introduce data attributes only monitoring SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 01/19] mm/damon/core: introduce damon_probe->weight SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 02/19] mm/damon/core: ask apply_probes() ops callback to set sampling address SJ Park
2026-07-09 14:16 ` sashiko-bot
2026-07-09 14:47 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 03/19] mm/damon/paddr: set samples in apply_probes() if requested SJ Park
2026-07-09 14:21 ` sashiko-bot
2026-07-09 14:48 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 04/19] mm/damon/core: ask apply_probe() to return max probe hits weighted sum SJ Park
2026-07-09 14:16 ` sashiko-bot
2026-07-09 14:49 ` SJ Park
2026-07-09 14:05 ` SJ Park [this message]
2026-07-09 14:05 ` [RFC PATCH v1.2 06/19] mm/damon/paddr: respect return_max_wsum SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 07/19] mm/damon/core: use abs_diff() instead of abs() SJ Park
2026-07-09 14:32 ` sashiko-bot
2026-07-09 14:54 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 08/19] mm/damon/core: extend merge function to work with probe hits SJ Park
2026-07-09 14:32 ` sashiko-bot
2026-07-09 14:56 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 09/19] mm/damon/core: disallow probe_hits overflow on attrs only monitoring SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 10/19] mm/damon/core: validate params for probe hits weighted sum overflow SJ Park
2026-07-09 14:36 ` sashiko-bot
2026-07-09 14:58 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 11/19] mm/damon/core: disable access monitoring when probe weights are set SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 12/19] mm/damon/core: set samples in apply_probes() if " SJ Park
2026-07-09 14:48 ` sashiko-bot
2026-07-09 15:00 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 13/19] mm/damon/core: s/max_nr_accesses/max_merge_score/ in kdamond_fn() SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 14/19] mm/damon/core: get merge threshold from probe hits when weights are set SJ Park
2026-07-09 14:49 ` sashiko-bot
2026-07-09 15:02 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 15/19] mm/damon/core: implement damon_has_probe_weight() SJ Park
2026-07-09 14:56 ` sashiko-bot
2026-07-09 15:03 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 16/19] mm/damon/sysfs: implement probe/weight file SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 17/19] Docs/mm/damon/design: document attrs-only monitoring SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 18/19] Docs/admin-guide/mm/damon/usage: document weight sysfs file SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 19/19] Docs/ABI/damon: document probe weight file SJ Park
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260709140600.90950-6-sj@kernel.org \
--to=sj@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=damon@lists.linux.dev \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox