From: sashiko-bot@kernel.org
To: "SJ Park" <sj@kernel.org>
Cc: damon@lists.linux.dev
Subject: Re: [RFC PATCH v1.2 04/19] mm/damon/core: ask apply_probe() to return max probe hits weighted sum
Date: Thu, 09 Jul 2026 14:16:38 +0000 [thread overview]
Message-ID: <20260709141640.249B71F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260709140600.90950-5-sj@kernel.org>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Medium] The `damon_pa_apply_probes` callback unconditionally returns 0 instead of computing and returning the maximum probe hits weighted sum when `return_max_wsum` is true, violating the updated API contract.
--
--- Patch [4]: [RFC PATCH v1.2 04/19] mm/damon/core: ask apply_probe() to return max probe hits weighted sum ---
commit ed82d24ec75fdb639533062e293614cb1cebe866
Author: SJ Park <sj@kernel.org>
mm/damon/core: ask apply_probe() to return max probe hits weighted sum
This commit updates the apply_probes() callback protocol in the DAMON
operations to optionally return the maximum probe hits weighted sum. This
value is intended to help the core layer adjust regions in the future.
> diff --git a/include/linux/damon.h b/include/linux/damon.h
> index 3c2a4d673bf62..4e1845ce83870 100644
> --- a/include/linux/damon.h
> +++ b/include/linux/damon.h
> @@ -648,7 +648,9 @@ enum damon_ops_id {
> * of its update. The value will be used for regions adjustment threshold.
> * @apply_probes should apply the data attribute probes to each region and
> * accordingly update the probe hits counter of the region. It should also
> - * &set sampling_addr of each region if ``set_samples`` is true.
> + * &set sampling_addr of each region if ``set_samples`` is true. It should
> + * also return maximum probe hits weighted sum of regions if
> + * ``return_max_wsum`` is true.
> * @get_scheme_score should return the priority score of a region for a scheme
> * as an integer in [0, &DAMOS_MAX_SCORE].
> * @apply_scheme is called from @kdamond when a region for user provided
[ ... ]
> diff --git a/mm/damon/paddr.c b/mm/damon/paddr.c
> index ff4fcca949660..3eba3564a31fc 100644
> --- a/mm/damon/paddr.c
> +++ b/mm/damon/paddr.c
> @@ -166,7 +166,8 @@ static bool damon_pa_filter_pass(phys_addr_t pa, struct folio *folio,
> return pass;
> }
>
> -static void damon_pa_apply_probes(struct damon_ctx *ctx, bool set_samples)
> +static unsigned int damon_pa_apply_probes(struct damon_ctx *ctx,
> + bool set_samples, bool return_max_wsum)
> {
> struct damon_target *t;
> struct damon_region *r;
> @@ -194,6 +195,7 @@ static void damon_pa_apply_probes(struct damon_ctx *ctx, bool set_samples)
> folio_put(folio);
> }
> }
> + return 0;
[Severity: Medium]
The kernel-doc for apply_probes states it should return the maximum probe hits
weighted sum if return_max_wsum is true.
However, damon_pa_apply_probes() unconditionally returns 0 here without
computing the weighted sum.
Will this cause the core layer to receive an incorrect threshold of 0 when it
starts passing return_max_wsum = true in the future?
> }
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260709140600.90950-1-sj@kernel.org?part=4
next prev parent reply other threads:[~2026-07-09 14:16 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-09 14:05 [RFC PATCH v1.2 00/19] mm/damon: introduce data attributes only monitoring SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 01/19] mm/damon/core: introduce damon_probe->weight SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 02/19] mm/damon/core: ask apply_probes() ops callback to set sampling address SJ Park
2026-07-09 14:16 ` sashiko-bot
2026-07-09 14:47 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 03/19] mm/damon/paddr: set samples in apply_probes() if requested SJ Park
2026-07-09 14:21 ` sashiko-bot
2026-07-09 14:48 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 04/19] mm/damon/core: ask apply_probe() to return max probe hits weighted sum SJ Park
2026-07-09 14:16 ` sashiko-bot [this message]
2026-07-09 14:49 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 05/19] mm/damon/core: implement damon_probe_hits_wsum() SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 06/19] mm/damon/paddr: respect return_max_wsum SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 07/19] mm/damon/core: use abs_diff() instead of abs() SJ Park
2026-07-09 14:32 ` sashiko-bot
2026-07-09 14:54 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 08/19] mm/damon/core: extend merge function to work with probe hits SJ Park
2026-07-09 14:32 ` sashiko-bot
2026-07-09 14:56 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 09/19] mm/damon/core: disallow probe_hits overflow on attrs only monitoring SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 10/19] mm/damon/core: validate params for probe hits weighted sum overflow SJ Park
2026-07-09 14:36 ` sashiko-bot
2026-07-09 14:58 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 11/19] mm/damon/core: disable access monitoring when probe weights are set SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 12/19] mm/damon/core: set samples in apply_probes() if " SJ Park
2026-07-09 14:48 ` sashiko-bot
2026-07-09 15:00 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 13/19] mm/damon/core: s/max_nr_accesses/max_merge_score/ in kdamond_fn() SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 14/19] mm/damon/core: get merge threshold from probe hits when weights are set SJ Park
2026-07-09 14:49 ` sashiko-bot
2026-07-09 15:02 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 15/19] mm/damon/core: implement damon_has_probe_weight() SJ Park
2026-07-09 14:56 ` sashiko-bot
2026-07-09 15:03 ` SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 16/19] mm/damon/sysfs: implement probe/weight file SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 17/19] Docs/mm/damon/design: document attrs-only monitoring SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 18/19] Docs/admin-guide/mm/damon/usage: document weight sysfs file SJ Park
2026-07-09 14:05 ` [RFC PATCH v1.2 19/19] Docs/ABI/damon: document probe weight file SJ Park
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260709141640.249B71F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=damon@lists.linux.dev \
--cc=sashiko-reviews@lists.linux.dev \
--cc=sj@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox