DPDK-dev Archive on lore.kernel.org
 help / color / mirror / Atom feed
* [RFC 0/2] bpf_def.h cleanups
@ 2026-08-05  9:46 Marat Khalili
  2026-08-05  9:46 ` [RFC 1/2] bpf: make bpf_def.h private Marat Khalili
                   ` (2 more replies)
  0 siblings, 3 replies; 16+ messages in thread
From: Marat Khalili @ 2026-08-05  9:46 UTC (permalink / raw)
  Cc: dev, stephen, thomas

This patch set contains two patches, first of which is a prerequisite
for the second but can also be considered and applied independently.

Marat Khalili (2):
  bpf: make bpf_def.h private
  bpf: rename macros to match Linux kernel

 app/test/test_bpf.c              | 1685 +++++++++++++++---------------
 app/test/test_bpf_validate.c     |  268 ++---
 lib/bpf/bpf_convert.c            |   78 +-
 lib/bpf/bpf_def.h                |   91 +-
 lib/bpf/bpf_dump.c               |   45 +-
 lib/bpf/bpf_exec.c               |  156 +--
 lib/bpf/bpf_impl.h               |    5 +-
 lib/bpf/bpf_jit_arm64.c          |  218 ++--
 lib/bpf/bpf_jit_x86.c            |  312 +++---
 lib/bpf/bpf_load.c               |    2 +-
 lib/bpf/bpf_load_elf.c           |   24 +-
 lib/bpf/bpf_validate.c           |  310 +++---
 lib/bpf/bpf_validate.h           |    4 +-
 lib/bpf/bpf_validate_debug.c     |    6 +-
 lib/bpf/meson.build              |    2 +-
 lib/bpf/rte_bpf.h                |   35 +-
 lib/bpf/rte_bpf_validate_debug.h |    8 +-
 17 files changed, 1623 insertions(+), 1626 deletions(-)

-- 
2.43.0


^ permalink raw reply	[flat|nested] 16+ messages in thread

end of thread, other threads:[~2026-09-21 20:19 UTC | newest]

Thread overview: 16+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-08-05  9:46 [RFC 0/2] bpf_def.h cleanups Marat Khalili
2026-08-05  9:46 ` [RFC 1/2] bpf: make bpf_def.h private Marat Khalili
2026-08-05  9:46 ` [RFC 2/2] bpf: rename macros to match Linux kernel Marat Khalili
2026-09-11 12:44 ` [PATCH v2 0/2] bpf_def.h cleanups Marat Khalili
2026-09-11 12:44   ` [PATCH v2 1/2] bpf: make bpf_def.h private Marat Khalili
2026-09-16 12:59     ` Konstantin Ananyev
2026-09-11 12:44   ` [PATCH v2 2/2] bpf: rename macros to match Linux kernel Marat Khalili
2026-09-16 13:07     ` Konstantin Ananyev
2026-09-17 15:19   ` [PATCH v3 0/1] bpf_def.h cleanups Marat Khalili
2026-09-17 15:19     ` [PATCH v3 1/1] bpf: make bpf_def.h private Marat Khalili
2026-09-17 19:29       ` Marat Khalili
2026-09-18  9:21     ` [PATCH v4 0/1] bpf_def.h cleanups Marat Khalili
2026-09-18  9:21       ` [PATCH v4 1/1] bpf: make bpf_def.h private Marat Khalili
2026-09-18 10:28         ` Marat Khalili
2026-09-21 10:16         ` Marat Khalili
2026-09-21 20:19         ` Marat Khalili

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox