Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Jani Nikula <jani.nikula@linux.intel.com>
To: Suraj Kandpal <suraj.kandpal@intel.com>,
	intel-xe@lists.freedesktop.org, intel-gfx@lists.freedesktop.org
Cc: ankit.k.nautiyal@intel.com, arun.r.murthy@intel.com,
	Suraj Kandpal <suraj.kandpal@intel.com>
Subject: Re: [PATCH 02/18] drm/i915/dpll: Rename intel_dpll_funcs
Date: Fri, 09 May 2025 13:05:41 +0300	[thread overview]
Message-ID: <877c2qm74a.fsf@intel.com> (raw)
In-Reply-To: <20250509042729.1152004-3-suraj.kandpal@intel.com>

On Fri, 09 May 2025, Suraj Kandpal <suraj.kandpal@intel.com> wrote:
> Rename intel_dpll_funcs to intel_dpll_global_funcs so that later
> on intel_shared_dpll_funcs can be renamed to intel_dpll_funcs.
> This is done to move away from the shared naming convention since
> starting MTL dpll's are not shared among PHYs.
>
> Signed-off-by: Suraj Kandpal <suraj.kandpal@intel.com>

My gut feeling is that the whole dpll and shared dpll distinction was a
mistake, and we should just have one dpll framework. But let's see where
this goes.

Reviewed-by: Jani Nikula <jani.nikula@intel.com>

> ---
>  .../gpu/drm/i915/display/intel_display_core.h |  4 ++--
>  drivers/gpu/drm/i915/display/intel_dpll.c     | 22 +++++++++----------
>  2 files changed, 13 insertions(+), 13 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/display/intel_display_core.h b/drivers/gpu/drm/i915/display/intel_display_core.h
> index 6fc213f84e73..e0221e514326 100644
> --- a/drivers/gpu/drm/i915/display/intel_display_core.h
> +++ b/drivers/gpu/drm/i915/display/intel_display_core.h
> @@ -42,7 +42,7 @@ struct intel_color_funcs;
>  struct intel_crtc;
>  struct intel_crtc_state;
>  struct intel_dmc;
> -struct intel_dpll_funcs;
> +struct intel_dpll_global_funcs;
>  struct intel_dpll_mgr;
>  struct intel_fbdev;
>  struct intel_fdi_funcs;
> @@ -300,7 +300,7 @@ struct intel_display {
>  		const struct intel_cdclk_funcs *cdclk;
>  
>  		/* Display pll funcs */
> -		const struct intel_dpll_funcs *dpll;
> +		const struct intel_dpll_global_funcs *dpll;
>  
>  		/* irq display functions */
>  		const struct intel_hotplug_funcs *hotplug;
> diff --git a/drivers/gpu/drm/i915/display/intel_dpll.c b/drivers/gpu/drm/i915/display/intel_dpll.c
> index a9e9b98d0bf9..8db603d9c823 100644
> --- a/drivers/gpu/drm/i915/display/intel_dpll.c
> +++ b/drivers/gpu/drm/i915/display/intel_dpll.c
> @@ -24,7 +24,7 @@
>  #include "vlv_dpio_phy_regs.h"
>  #include "vlv_sideband.h"
>  
> -struct intel_dpll_funcs {
> +struct intel_dpll_global_funcs {
>  	int (*crtc_compute_clock)(struct intel_atomic_state *state,
>  				  struct intel_crtc *crtc);
>  	int (*crtc_get_shared_dpll)(struct intel_atomic_state *state,
> @@ -1690,45 +1690,45 @@ static int i8xx_crtc_compute_clock(struct intel_atomic_state *state,
>  	return 0;
>  }
>  
> -static const struct intel_dpll_funcs mtl_dpll_funcs = {
> +static const struct intel_dpll_global_funcs mtl_dpll_funcs = {
>  	.crtc_compute_clock = mtl_crtc_compute_clock,
>  };
>  
> -static const struct intel_dpll_funcs dg2_dpll_funcs = {
> +static const struct intel_dpll_global_funcs dg2_dpll_funcs = {
>  	.crtc_compute_clock = dg2_crtc_compute_clock,
>  };
>  
> -static const struct intel_dpll_funcs hsw_dpll_funcs = {
> +static const struct intel_dpll_global_funcs hsw_dpll_funcs = {
>  	.crtc_compute_clock = hsw_crtc_compute_clock,
>  	.crtc_get_shared_dpll = hsw_crtc_get_shared_dpll,
>  };
>  
> -static const struct intel_dpll_funcs ilk_dpll_funcs = {
> +static const struct intel_dpll_global_funcs ilk_dpll_funcs = {
>  	.crtc_compute_clock = ilk_crtc_compute_clock,
>  	.crtc_get_shared_dpll = ilk_crtc_get_shared_dpll,
>  };
>  
> -static const struct intel_dpll_funcs chv_dpll_funcs = {
> +static const struct intel_dpll_global_funcs chv_dpll_funcs = {
>  	.crtc_compute_clock = chv_crtc_compute_clock,
>  };
>  
> -static const struct intel_dpll_funcs vlv_dpll_funcs = {
> +static const struct intel_dpll_global_funcs vlv_dpll_funcs = {
>  	.crtc_compute_clock = vlv_crtc_compute_clock,
>  };
>  
> -static const struct intel_dpll_funcs g4x_dpll_funcs = {
> +static const struct intel_dpll_global_funcs g4x_dpll_funcs = {
>  	.crtc_compute_clock = g4x_crtc_compute_clock,
>  };
>  
> -static const struct intel_dpll_funcs pnv_dpll_funcs = {
> +static const struct intel_dpll_global_funcs pnv_dpll_funcs = {
>  	.crtc_compute_clock = pnv_crtc_compute_clock,
>  };
>  
> -static const struct intel_dpll_funcs i9xx_dpll_funcs = {
> +static const struct intel_dpll_global_funcs i9xx_dpll_funcs = {
>  	.crtc_compute_clock = i9xx_crtc_compute_clock,
>  };
>  
> -static const struct intel_dpll_funcs i8xx_dpll_funcs = {
> +static const struct intel_dpll_global_funcs i8xx_dpll_funcs = {
>  	.crtc_compute_clock = i8xx_crtc_compute_clock,
>  };

-- 
Jani Nikula, Intel

  reply	other threads:[~2025-05-09 10:05 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-05-09  4:27 [PATCH 00/18] DPLL framework redesign Suraj Kandpal
2025-05-09  4:27 ` [PATCH 01/18] drm/i915/dpll: Rename intel_dpll Suraj Kandpal
2025-05-09 10:04   ` Jani Nikula
2025-05-09  4:27 ` [PATCH 02/18] drm/i915/dpll: Rename intel_dpll_funcs Suraj Kandpal
2025-05-09 10:05   ` Jani Nikula [this message]
2025-05-09  4:27 ` [PATCH 03/18] drm/i915/dpll: Rename intel_shared_dpll_state Suraj Kandpal
2025-05-09 10:07   ` Jani Nikula
2025-05-09  4:27 ` [PATCH 04/18] drm/i915/dpll: Rename macro for_each_shared_dpll Suraj Kandpal
2025-05-09 10:07   ` Jani Nikula
2025-05-09  4:27 ` [PATCH 05/18] drm/i915/dpll: Rename intel_shared_dpll_funcs Suraj Kandpal
2025-05-09 10:08   ` Jani Nikula
2025-05-09  4:27 ` [PATCH 06/18] drm/i915/dpll: Rename intel_shared_dpll Suraj Kandpal
2025-05-09 10:13   ` Jani Nikula
2025-05-12  4:00     ` Kandpal, Suraj
2025-05-09  4:27 ` [PATCH 07/18] drm/i915/dpll: Move away from using shared dpll Suraj Kandpal
2025-05-09 10:17   ` Jani Nikula
2025-05-12  4:02     ` Kandpal, Suraj
2025-05-09  4:27 ` [PATCH 08/18] drm/i915/dpll: Rename crtc_get_shared_dpll Suraj Kandpal
2025-05-09 10:19   ` Jani Nikula
2025-05-09  4:27 ` [PATCH 09/18] drm/i915/dpll: Change argument for enable hook in intel_dpll_funcs Suraj Kandpal
2025-05-09 10:22   ` Jani Nikula
2025-05-09  4:27 ` [PATCH 10/18] drm/i915/drm: Rename disable hook in intel_dpll_global_func Suraj Kandpal
2025-05-09 10:24   ` Jani Nikula
2025-05-09  4:27 ` [PATCH 11/18] drm/i915/dpll: Introduce new hook in intel_dpll_funcs Suraj Kandpal
2025-05-09 10:25   ` Jani Nikula
2025-05-09  4:27 ` [PATCH 12/18] drm/i915/dpll: Add intel_encoder argument to get_hw_state hook Suraj Kandpal
2025-05-09 10:25   ` Jani Nikula
2025-05-09  4:27 ` [PATCH 13/18] drm/i915/dpll: Change arguments for get_freq hook Suraj Kandpal
2025-05-09 10:27   ` Jani Nikula
2025-05-09  4:27 ` [PATCH 14/18] drm/i915/dpll: Rename intel_[enable/disable]_dpll Suraj Kandpal
2025-05-09 10:29   ` Jani Nikula
2025-05-12  3:19     ` Kandpal, Suraj
2025-05-09  4:27 ` [PATCH 15/18] drm/i915/dpll: Rename intel_unreference_dpll__crtc Suraj Kandpal
2025-05-09 10:31   ` Jani Nikula
2025-05-12  4:27     ` Kandpal, Suraj
2025-05-09  4:27 ` [PATCH 16/18] drm/i915/dpll: Rename intel_<release/reserve>_dpll Suraj Kandpal
2025-05-09 10:32   ` Jani Nikula
2025-05-09  4:27 ` [PATCH 17/18] drm/i915/dpll: Rename intel_compute_dpll Suraj Kandpal
2025-05-09 10:33   ` Jani Nikula
2025-05-09  4:27 ` [PATCH 18/18] drm/i915/dpll: Rename intel_update_active_dpll Suraj Kandpal
2025-05-09 10:33   ` Jani Nikula
  -- strict thread matches above, loose matches on Subject: below --
2025-04-07  8:16 [PATCH 00/18] DPLL framework redesign Suraj Kandpal
2025-04-07  8:16 ` [PATCH 02/18] drm/i915/dpll: Rename intel_dpll_funcs Suraj Kandpal

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=877c2qm74a.fsf@intel.com \
    --to=jani.nikula@linux.intel.com \
    --cc=ankit.k.nautiyal@intel.com \
    --cc=arun.r.murthy@intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=intel-xe@lists.freedesktop.org \
    --cc=suraj.kandpal@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox