From: Dave Jiang <dave.jiang@intel.com>
To: Jonathan Cameron <jic23@kernel.org>
Cc: Anisa Su <anisa.su887@gmail.com>,
linux-cxl@vger.kernel.org,
Alison Schofield <alison.schofield@intel.com>,
Davidlohr Bueso <dave@stgolabs.net>,
Li Ming <ming.li@zohomail.com>, Gregory Price <gourry@gourry.net>,
Richard Cheng <icheng@nvidia.com>,
Ben Cheatham <benjamin.cheatham@amd.com>,
Ira Weiny <iweiny@kernel.org>, Anisa Su <anisa.su@samsung.com>,
Wonjae Lee <wj28.lee@samsung.com>,
Junhee Park <jh9934.park@samsung.com>,
Heesoo Kim <habil.kim@samsung.com>
Subject: Re: [PATCH v14 6/8] cxl/mem: Configure dynamic capacity interrupts
Date: Mon, 21 Sep 2026 17:45:56 -0700 [thread overview]
Message-ID: <a26d002f-1dcf-4bf4-bfd5-dd587c559029@intel.com> (raw)
In-Reply-To: <20260922004228.5a0c027b@jic23-hlaptop>
On 9/21/26 4:42 PM, Jonathan Cameron wrote:
>
>>> diff --git a/tools/testing/cxl/test/mem.c b/tools/testing/cxl/test/mem.c
>>> index 7b756000a1a6..6ef47265da10 100644
>>> --- a/tools/testing/cxl/test/mem.c
>>> +++ b/tools/testing/cxl/test/mem.c
>>> @@ -1818,7 +1818,10 @@ static int cxl_mock_mem_probe(struct platform_device *pdev)
>>> if (rc)
>>> dev_dbg(dev, "No CXL FWCTL setup\n");
>>>
>>> - cxl_mem_get_event_records(mds, CXLDEV_EVENT_STATUS_ALL);
>>> + cxl_mem_get_event_records(mds, CXLDEV_EVENT_STATUS_INFO |
>>> + CXLDEV_EVENT_STATUS_WARN |
>>> + CXLDEV_EVENT_STATUS_FAIL |
>>> + CXLDEV_EVENT_STATUS_FATAL);
>>
>> Second time I'm seeing this constructed mask being used in this commit. Maybe create a define for it?
>>
>> s/CXLDEV_EVENT_STATUS_ALL/CXLDEV_EVENT_STATUS_BASE/ perhaps?
>
> That was Anisa acting on my feedbakc on previous.
> I don't like _ALL because we already have an example of the spec
> expanding and the definition becoming messy. But mainly I was
> pushing back against _ALL + masking with one element we didn't
> want as fragile. So I'm not against _ALL if it is made up of
> another define + DCD (for now) and that other define can be
> used in places like this.
>
> Bikeshed time... BASE is usually a define for a reg address and it is
> is hard to come up with a name for that when it is a mixture of
> RAS stuff and INFO which can be a wide range of random nasty
> and nice things.
>
> So with the right name seems fine to have what Dave suggests.
> I'm just not sure what that name is! Hence I'd just stick
> to the long hand option.
Yeah if we can't come up with anything good then leave it as is.
>
> Jonathan
>
>>
>>> cxl_mock_test_feat_init(mdata);
>>>
>>> return 0;
>>
>>
>
next prev parent reply other threads:[~2026-09-22 0:45 UTC|newest]
Thread overview: 41+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-18 20:30 [PATCH v14 0/8] DCD Prep Series Anisa Su
2026-09-18 20:30 ` [PATCH v14 1/8] cxl/mbox: Flag support for Dynamic Capacity Devices (DCD) Anisa Su
2026-09-18 20:30 ` [PATCH v14 2/8] cxl/mem: Read dynamic capacity configuration from the device Anisa Su
2026-09-18 20:44 ` sashiko-bot
2026-09-18 22:59 ` Anisa Su
2026-09-21 21:50 ` Dave Jiang
2026-09-21 23:19 ` Jonathan Cameron
2026-09-22 3:44 ` Richard Cheng
2026-09-24 0:55 ` Jonathan Cameron
2026-09-24 7:01 ` Anisa Su
2026-09-18 20:30 ` [PATCH v14 3/8] cxl/cdat: Gather DSMAS data for DCD partitions Anisa Su
2026-09-21 21:55 ` Dave Jiang
2026-09-24 5:12 ` Anisa Su
2026-09-21 23:27 ` Jonathan Cameron
2026-09-24 5:01 ` Anisa Su
2026-09-22 3:53 ` Richard Cheng
2026-09-22 17:08 ` Dave Jiang
2026-09-22 21:15 ` Anisa Su
2026-09-22 23:05 ` Dave Jiang
2026-09-23 0:05 ` Anisa Su
2026-09-23 15:35 ` Dave Jiang
2026-09-24 4:58 ` Anisa Su
2026-09-18 20:30 ` [PATCH v14 4/8] cxl/events: Split event msgnum configuration from irq setup Anisa Su
2026-09-22 5:35 ` Richard Cheng
2026-09-18 20:30 ` [PATCH v14 5/8] cxl/pci: Factor out interrupt policy check Anisa Su
2026-09-22 5:37 ` Richard Cheng
2026-09-18 20:30 ` [PATCH v14 6/8] cxl/mem: Configure dynamic capacity interrupts Anisa Su
2026-09-18 20:43 ` sashiko-bot
2026-09-18 23:38 ` Anisa Su
2026-09-21 22:00 ` Dave Jiang
2026-09-21 23:42 ` Jonathan Cameron
2026-09-22 0:45 ` Dave Jiang [this message]
2026-09-22 21:22 ` Anisa Su
2026-09-24 0:58 ` Jonathan Cameron
2026-09-22 5:48 ` Richard Cheng
2026-09-22 9:15 ` Richard Cheng
2026-09-18 20:30 ` [PATCH v14 7/8] cxl/core: Enforce partition order/simplify partition calls Anisa Su
2026-09-18 20:30 ` [PATCH v14 8/8] Documentation/cxl: Document DPA partition layout and ordering rules Anisa Su
2026-09-21 22:02 ` Dave Jiang
2026-09-28 21:53 ` Anisa Su
2026-09-28 22:36 ` Dave Jiang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=a26d002f-1dcf-4bf4-bfd5-dd587c559029@intel.com \
--to=dave.jiang@intel.com \
--cc=alison.schofield@intel.com \
--cc=anisa.su887@gmail.com \
--cc=anisa.su@samsung.com \
--cc=benjamin.cheatham@amd.com \
--cc=dave@stgolabs.net \
--cc=gourry@gourry.net \
--cc=habil.kim@samsung.com \
--cc=icheng@nvidia.com \
--cc=iweiny@kernel.org \
--cc=jh9934.park@samsung.com \
--cc=jic23@kernel.org \
--cc=linux-cxl@vger.kernel.org \
--cc=ming.li@zohomail.com \
--cc=wj28.lee@samsung.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox