Linux PCI subsystem development
 help / color / mirror / Atom feed
* [PATCH 0/2] PCI: dwc: Make the MSI domain naming explicit
@ 2026-09-30  2:22 Shawn Lin
  2026-09-30  2:22 ` [PATCH 1/2] PCI: dwc: Rename dw_pcie_allocate_domains to dw_pcie_allocate_msi_domains Shawn Lin
  2026-09-30  2:22 ` [PATCH 2/2] PCI: dwc: Rename pp->irq_domain to pp->msi_irq_domain Shawn Lin
  0 siblings, 2 replies; 6+ messages in thread
From: Shawn Lin @ 2026-09-30  2:22 UTC (permalink / raw)
  To: Manivannan Sadhasivam, Bjorn Helgaas; +Cc: linux-pci, Shawn Lin


I was looking into whether the DWC core provides a common INTx irq
domain registration and handling flow, as several glue drivers owning
a legacy interrupt controller copy-paste the same code (get the
"legacy-interrupt-controller" child node, create a linear domain with
a one-line .map callback, install a chained handler).

The DWC core has no INTx equivalent at all: dw_pcie_allocate_domains()
looks like it could be that helper at first glance, but it only
creates the MSI parent irq domain (msi_create_parent_irq_domain() with
DOMAIN_BUS_PCI_MSI). Likewise, struct dw_pcie_rp::irq_domain only
serves the MSI parent domain.

So make the naming explicit:

patch 1 renames dw_pcie_allocate_domains() to
dw_pcie_allocate_msi_domains().

patch 2 renames struct dw_pcie_rp::irq_domain to ::msi_irq_domain.



Shawn Lin (2):
  PCI: dwc: Rename dw_pcie_allocate_domains to
    dw_pcie_allocate_msi_domains
  PCI: dwc: Rename pp->irq_domain to pp->msi_irq_domain

 drivers/pci/controller/dwc/pci-dra7xx.c           |  2 +-
 drivers/pci/controller/dwc/pci-keystone.c         |  4 ++--
 drivers/pci/controller/dwc/pcie-designware-host.c | 14 +++++++-------
 drivers/pci/controller/dwc/pcie-designware.h      |  6 +++---
 4 files changed, 13 insertions(+), 13 deletions(-)

-- 
2.7.4


^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2026-09-30  9:17 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-09-30  2:22 [PATCH 0/2] PCI: dwc: Make the MSI domain naming explicit Shawn Lin
2026-09-30  2:22 ` [PATCH 1/2] PCI: dwc: Rename dw_pcie_allocate_domains to dw_pcie_allocate_msi_domains Shawn Lin
2026-09-30  9:16   ` sashiko-bot
2026-09-30  2:22 ` [PATCH 2/2] PCI: dwc: Rename pp->irq_domain to pp->msi_irq_domain Shawn Lin
2026-09-30  4:10   ` Vignesh Raghavendra
2026-09-30  9:17   ` sashiko-bot

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox