X86 platform drivers
 help / color / mirror / Atom feed
* [PATCH v4 0/3] int3472: Support GPIO con_id based on _HID
@ 2025-01-31  7:37 Sakari Ailus
  2025-01-31  7:37 ` [PATCH v4 1/3] platform/x86: int3472: Use correct type for "polarity", call it gpio_flags Sakari Ailus
                   ` (4 more replies)
  0 siblings, 5 replies; 9+ messages in thread
From: Sakari Ailus @ 2025-01-31  7:37 UTC (permalink / raw)
  To: Daniel Scally, Hans de Goede, Ilpo Järvinen
  Cc: platform-driver-x86, Andy Shevchenko, laurent.pinchart, hverkuil,
	linux-media

Hi folks,

One patch turned into a set, the second patch being the original one.

since v3:

- Add a patch (first one) to switch to unsigned long type for polarity
  field and renames it as gpio_flags.

- Use a polarity_low boolean field for indicating the GPIO polarity. This
  is turned to gpio_flags in int3472_get_con_id_and_polarity().

- Put the new polarity_low bool field next to the u8's for better struct
  packing.

- Add a patch (last one) to rename "func" as "con_id" which is used
  throughout the GPIO framework.

Sakari Ailus (3):
  platform/x86: int3472: Use correct type for "polarity", call it
    gpio_flags
  platform/x86: int3472: Call "reset" GPIO "enable" for INT347E
  platform/x86: int3472: Call "func" "con_id" instead

 drivers/platform/x86/intel/int3472/discrete.c | 98 +++++++++++++------
 1 file changed, 68 insertions(+), 30 deletions(-)

-- 
2.39.5


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2025-01-31 17:20 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-01-31  7:37 [PATCH v4 0/3] int3472: Support GPIO con_id based on _HID Sakari Ailus
2025-01-31  7:37 ` [PATCH v4 1/3] platform/x86: int3472: Use correct type for "polarity", call it gpio_flags Sakari Ailus
2025-01-31  7:37 ` [PATCH v4 2/3] platform/x86: int3472: Call "reset" GPIO "enable" for INT347E Sakari Ailus
2025-01-31 11:22   ` Andy Shevchenko
2025-01-31 11:57     ` Sakari Ailus
2025-01-31 17:20       ` Andy Shevchenko
2025-01-31  7:37 ` [PATCH v4 3/3] platform/x86: int3472: Call "func" "con_id" instead Sakari Ailus
2025-01-31  9:16 ` [PATCH v4 0/3] int3472: Support GPIO con_id based on _HID Hans de Goede
2025-01-31 11:24 ` Andy Shevchenko

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox