X86 platform drivers
 help / color / mirror / Atom feed
From: Mario Limonciello <mario.limonciello@amd.com>
To: Shyam Sundar S K <Shyam-sundar.S-k@amd.com>,
	hansg@kernel.org, ilpo.jarvinen@linux.intel.com
Cc: platform-driver-x86@vger.kernel.org, Patil.Reddy@amd.com,
	lizhi.hou@amd.com
Subject: Re: [PATCH v2 0/5] PMF NPU metrics cleanup, command flag cleanup, and amdxdna integration
Date: Wed, 12 Nov 2025 11:21:14 -0600	[thread overview]
Message-ID: <e451a128-cd81-4ec9-909a-47b960f3946c@amd.com> (raw)
In-Reply-To: <20251111063737.4156385-1-Shyam-sundar.S-k@amd.com>

On 11/11/25 12:37 AM, Shyam Sundar S K wrote:
> This series streamlines NPU-related handling in AMD PMF, adds a
> lightweight in-kernel interface for fetching NPU metrics from PMF, and
> hooks AMD XDNA to that interface to expose real-time NPU power data to
> user space.
> 
> Changes include renaming legacy IPU fields to NPU in the metrics structure
> replacing ambiguous booleans and magic values with explicit
> SET_CMD/GET_CMD and METRICS_TABLE_ID constants, introducing an exported
> amd_pmf_get_npu_data() API (guarded by a mutex and platform checks) to
> pull NPU metrics from the SMU, and wiring those metrics into the amdxdna
> driver.
> 
> v2:
> ----
>   - Split the series into multiple patches per v1 feedback
>   - Added preliminary PMF driver cleanups as preparatory patches
>   - Introduced an initial amd_xdna patch that consumes PMF-provided data to
>     establish the plumbing; additional logic can be layered on in future
>     patches as more PMF metrics are utilized.
> 
> Shyam Sundar S K (4):
>    platform/x86/amd/pmf: Rename IPU metrics fields to NPU for consistency
>    platform/x86/amd/pmf: Use explicit SET_CMD/GET_CMD flags in
>      amd_pmf_send_cmd()
>    platform/x86/amd/pmf: replace magic table id with METRICS_TABLE_ID
>    platform/x86/amd/pmf: Introduce new interface to export NPU metrics
> 
> VinitKumar Shukla (1):
>    accel/amdxdna: Provide real-time NPU power estimate via AMD PMF
> 
>   drivers/accel/amdxdna/aie2_pci.h         |  2 +
>   drivers/accel/amdxdna/aie2_smu.c         | 12 ++++
>   drivers/platform/x86/amd/pmf/auto-mode.c | 14 ++---
>   drivers/platform/x86/amd/pmf/cnqf.c      | 14 ++---
>   drivers/platform/x86/amd/pmf/core.c      | 71 +++++++++++++++++++++++-
>   drivers/platform/x86/amd/pmf/pmf.h       | 18 ++++--
>   drivers/platform/x86/amd/pmf/spc.c       |  2 +-
>   drivers/platform/x86/amd/pmf/sps.c       | 38 ++++++-------
>   drivers/platform/x86/amd/pmf/tee-if.c    | 20 +++----
>   include/linux/amd-pmf-io.h               | 21 +++++++
>   10 files changed, 159 insertions(+), 53 deletions(-)
> 

Which tree do you think this should merge through?
drm-misc or platform-x86?

I tried and the series cleanly applies to both and compiles on both.  So 
I think it can go either way.

  parent reply	other threads:[~2025-11-12 17:21 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-11-11  6:37 [PATCH v2 0/5] PMF NPU metrics cleanup, command flag cleanup, and amdxdna integration Shyam Sundar S K
2025-11-11  6:37 ` [PATCH v2 1/5] platform/x86/amd/pmf: Rename IPU metrics fields to NPU for consistency Shyam Sundar S K
2025-11-18 15:36   ` Ilpo Järvinen
2025-11-11  6:37 ` [PATCH v2 2/5] platform/x86/amd/pmf: Use explicit SET_CMD/GET_CMD flags in amd_pmf_send_cmd() Shyam Sundar S K
2025-11-18 15:41   ` Ilpo Järvinen
2025-11-18 17:03     ` Shyam Sundar S K
2025-11-18 17:08       ` Ilpo Järvinen
2025-11-11  6:37 ` [PATCH v2 3/5] platform/x86/amd/pmf: replace magic table id with METRICS_TABLE_ID Shyam Sundar S K
2025-11-18 15:44   ` Ilpo Järvinen
2025-11-11  6:37 ` [PATCH v2 4/5] platform/x86/amd/pmf: Introduce new interface to export NPU metrics Shyam Sundar S K
2025-11-18 15:54   ` Ilpo Järvinen
2025-11-11  6:37 ` [PATCH v2 5/5] accel/amdxdna: Provide real-time NPU power estimate via AMD PMF Shyam Sundar S K
2025-11-12 18:03   ` Mario Limonciello
2025-11-13  7:33     ` Shyam Sundar S K
2025-11-14 16:56       ` Mario Limonciello
2025-11-18 15:59         ` Ilpo Järvinen
2025-11-18 16:01           ` Ilpo Järvinen
2025-11-18 16:46             ` Shyam Sundar S K
2025-11-19 12:44               ` Ilpo Järvinen
2025-11-20 10:55                 ` Shyam Sundar S K
2025-11-12 17:21 ` Mario Limonciello [this message]
2025-11-13  7:37   ` [PATCH v2 0/5] PMF NPU metrics cleanup, command flag cleanup, and amdxdna integration Shyam Sundar S K

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e451a128-cd81-4ec9-909a-47b960f3946c@amd.com \
    --to=mario.limonciello@amd.com \
    --cc=Patil.Reddy@amd.com \
    --cc=Shyam-sundar.S-k@amd.com \
    --cc=hansg@kernel.org \
    --cc=ilpo.jarvinen@linux.intel.com \
    --cc=lizhi.hou@amd.com \
    --cc=platform-driver-x86@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox