From: Manasi Navare <manasi.d.navare@intel.com>
To: intel-gfx@lists.freedesktop.org
Cc: Jani Nikula <jani.nikula@intel.com>
Subject: Re: [PATCH 1/2] drm/i915/display: Rename update_crtcs() to commit_modeset_enables()
Date: Thu, 29 Aug 2019 14:17:51 -0700 [thread overview]
Message-ID: <20190829211751.GJ701@intel.com> (raw)
In-Reply-To: <20190828171110.GB4922@intel.com>
Thanks for the review pushed to dinq
Manasi
On Wed, Aug 28, 2019 at 10:11:10AM -0700, Manasi Navare wrote:
> On Tue, Aug 27, 2019 at 03:17:34PM -0700, Manasi Navare wrote:
> > This patch has no functional changes. This just renames the update_crtcs()
> > hooks to commit_modeset_enables() to match the drm_atomic helper naming
> > conventions.
>
> Maarten, do you also want to avoid having a separate hook here for enables() for ICL?
> Instead use the same intel_commit_modeset_enables() for even ICL+ with special
> handling for trans_port_sync cases?
>
> Other than that, do I have your r-b on this rename?
>
> Manasi
>
> >
> > v2:
> > * Rebase on drm-tip
> >
> > Suggested-by: Daniel Vetter <daniel.vetter@intel.com>
> > Cc: Ville Syrjälä <ville.syrjala@linux.intel.com>
> > Cc: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
> > Cc: Matt Roper <matthew.d.roper@intel.com>
> > Cc: Jani Nikula <jani.nikula@intel.com>
> > Signed-off-by: Manasi Navare <manasi.d.navare@intel.com>
> > ---
> > drivers/gpu/drm/i915/display/intel_display.c | 10 +++++-----
> > drivers/gpu/drm/i915/i915_drv.h | 2 +-
> > 2 files changed, 6 insertions(+), 6 deletions(-)
> >
> > diff --git a/drivers/gpu/drm/i915/display/intel_display.c b/drivers/gpu/drm/i915/display/intel_display.c
> > index 9d8313850416..23c8c7f5c47a 100644
> > --- a/drivers/gpu/drm/i915/display/intel_display.c
> > +++ b/drivers/gpu/drm/i915/display/intel_display.c
> > @@ -13758,7 +13758,7 @@ static void intel_update_crtc(struct intel_crtc *crtc,
> > intel_finish_crtc_commit(state, crtc);
> > }
> >
> > -static void intel_update_crtcs(struct intel_atomic_state *state)
> > +static void intel_commit_modeset_enables(struct intel_atomic_state *state)
> > {
> > struct intel_crtc *crtc;
> > struct intel_crtc_state *old_crtc_state, *new_crtc_state;
> > @@ -13773,7 +13773,7 @@ static void intel_update_crtcs(struct intel_atomic_state *state)
> > }
> > }
> >
> > -static void skl_update_crtcs(struct intel_atomic_state *state)
> > +static void skl_commit_modeset_enables(struct intel_atomic_state *state)
> > {
> > struct drm_i915_private *dev_priv = to_i915(state->base.dev);
> > struct intel_crtc *crtc;
> > @@ -14014,7 +14014,7 @@ static void intel_atomic_commit_tail(struct intel_atomic_state *state)
> > intel_encoders_update_prepare(state);
> >
> > /* Now enable the clocks, plane, pipe, and connectors that we set up. */
> > - dev_priv->display.update_crtcs(state);
> > + dev_priv->display.commit_modeset_enables(state);
> >
> > if (state->modeset) {
> > intel_encoders_update_complete(state);
> > @@ -15926,9 +15926,9 @@ void intel_init_display_hooks(struct drm_i915_private *dev_priv)
> > }
> >
> > if (INTEL_GEN(dev_priv) >= 9)
> > - dev_priv->display.update_crtcs = skl_update_crtcs;
> > + dev_priv->display.commit_modeset_enables = skl_commit_modeset_enables;
> > else
> > - dev_priv->display.update_crtcs = intel_update_crtcs;
> > + dev_priv->display.commit_modeset_enables = intel_commit_modeset_enables;
> > }
> >
> > static i915_reg_t i915_vgacntrl_reg(struct drm_i915_private *dev_priv)
> > diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h
> > index b42651a387d9..75a42e8df67e 100644
> > --- a/drivers/gpu/drm/i915/i915_drv.h
> > +++ b/drivers/gpu/drm/i915/i915_drv.h
> > @@ -288,7 +288,7 @@ struct drm_i915_display_funcs {
> > struct intel_atomic_state *old_state);
> > void (*crtc_disable)(struct intel_crtc_state *old_crtc_state,
> > struct intel_atomic_state *old_state);
> > - void (*update_crtcs)(struct intel_atomic_state *state);
> > + void (*commit_modeset_enables)(struct intel_atomic_state *state);
> > void (*audio_codec_enable)(struct intel_encoder *encoder,
> > const struct intel_crtc_state *crtc_state,
> > const struct drm_connector_state *conn_state);
> > --
> > 2.19.1
> >
> _______________________________________________
> Intel-gfx mailing list
> Intel-gfx@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/intel-gfx
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2019-08-29 21:16 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-08-27 22:17 [PATCH 0/2] Transcoder Port Sync preparation refactoring/renaming Manasi Navare
2019-08-27 22:17 ` [PATCH 1/2] drm/i915/display: Rename update_crtcs() to commit_modeset_enables() Manasi Navare
2019-08-28 17:11 ` Manasi Navare
2019-08-29 7:44 ` Maarten Lankhorst
2019-08-29 21:17 ` Manasi Navare [this message]
2019-08-27 22:17 ` [PATCH 2/2] drm/i915/display: Move the commit_tail() disable sequence to commit_modeset_disables() hook Manasi Navare
2019-08-28 6:30 ` Maarten Lankhorst
2019-08-28 17:09 ` Manasi Navare
2019-08-28 22:47 ` [PATCH v2 2/2] drm/i915/display: Move the commit_tail() disable sequence to separate function Manasi Navare
2019-08-29 7:30 ` Maarten Lankhorst
2019-08-29 21:18 ` Manasi Navare
2019-08-30 10:20 ` Maarten Lankhorst
2019-08-28 9:07 ` ✓ Fi.CI.BAT: success for Transcoder Port Sync preparation refactoring/renaming Patchwork
2019-08-28 23:20 ` ✗ Fi.CI.CHECKPATCH: warning for Transcoder Port Sync preparation refactoring/renaming (rev2) Patchwork
2019-08-29 4:33 ` ✓ Fi.CI.BAT: success " Patchwork
2019-08-29 10:06 ` ✓ Fi.CI.IGT: success for Transcoder Port Sync preparation refactoring/renaming Patchwork
2019-08-29 11:19 ` ✓ Fi.CI.IGT: success for Transcoder Port Sync preparation refactoring/renaming (rev2) Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190829211751.GJ701@intel.com \
--to=manasi.d.navare@intel.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jani.nikula@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox