Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: "Nautiyal, Ankit K" <ankit.k.nautiyal@intel.com>
To: "Jouni Högander" <jouni.hogander@intel.com>,
	intel-gfx@lists.freedesktop.org, intel-xe@lists.freedesktop.org
Subject: Re: [PATCH 01/11] drm/dp: Add Panel Replay capability bits from DP2.1 specification
Date: Tue, 20 May 2025 14:06:45 +0530	[thread overview]
Message-ID: <8af5523e-1732-4e53-86c4-36fb1465d585@intel.com> (raw)
In-Reply-To: <20250502085902.154740-2-jouni.hogander@intel.com>


On 5/2/2025 2:28 PM, Jouni Högander wrote:
> Add PANEL REPLAY CAPABILITY register (0xb1) bits.
>
> Signed-off-by: Jouni Högander <jouni.hogander@intel.com>
> ---
>   include/drm/display/drm_dp.h | 10 ++++++++--
>   1 file changed, 8 insertions(+), 2 deletions(-)
>
> diff --git a/include/drm/display/drm_dp.h b/include/drm/display/drm_dp.h
> index 3001c0b6e7bb3..47e7d55e2803f 100644
> --- a/include/drm/display/drm_dp.h
> +++ b/include/drm/display/drm_dp.h
> @@ -552,8 +552,14 @@
>   # define DP_PANEL_REPLAY_SU_SUPPORT			(1 << 1)
>   # define DP_PANEL_REPLAY_EARLY_TRANSPORT_SUPPORT	(1 << 2) /* eDP 1.5 */
>   
> -#define DP_PANEL_PANEL_REPLAY_CAPABILITY		0xb1


Though not introduced in this patch, the name 
DP_PANEL_PANEL_REPLAY_CAPABILITY doesn’t seem quite right.

Since we are adding bits for Panel Replay capabilities, would it be more 
appropriate to use DP_PANEL_REPLAY_CAPABILITY instead?

Also, IMHO, DP_PANEL_REPLAY_CAP could be renamed to 
DP_PANEL_REPLAY_CAP_SUPPORT for better clarity.

Lastly, since Panel Replay capabilities are defined from 0xb0 to 0xb6, 
perhaps we could introduce a DP_PANEL_REPLAY_CAP_SIZE to reflect the range?


Regards,

Ankit


> -# define DP_PANEL_PANEL_REPLAY_SU_GRANULARITY_REQUIRED	(1 << 5)
> +#define DP_PANEL_PANEL_REPLAY_CAPABILITY					0xb1
> +# define DP_PANEL_REPLAY_DSC_DECODE_CAPABILITY_IN_PR_SHIFT			1 /* DP 2.1 */
> +# define DP_PANEL_REPLAY_DSC_DECODE_CAPABILITY_IN_PR_MASK			(3 << 1)
> +# define DP_PANEL_REPLAY_ASYNC_VIDEO_TIMING_NOT_SUPPORTED_IN_PR			(1 << 3)
> +# define DP_PANEL_REPLAY_DSC_CRC_OF_MULTIPLE_SUS_SUPPORTED			(1 << 4)
> +# define DP_PANEL_PANEL_REPLAY_SU_GRANULARITY_REQUIRED				(1 << 5)
> +# define DP_PANEL_REPLAY_SU_Y_GRANULARITY_EXTENDED_CAPABILITY_SUPPORTED		(1 << 6)
> +# define DP_PANEL_REPLAY_LINK_OFF_SUPPORTED_IN_PR_AFTER_ADAPTIVE_SYNC_SDP	(1 << 7)
>   
>   #define DP_PANEL_PANEL_REPLAY_X_GRANULARITY		0xb2
>   #define DP_PANEL_PANEL_REPLAY_Y_GRANULARITY		0xb4

  parent reply	other threads:[~2025-05-20  8:37 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-05-02  8:58 [PATCH 00/11] Panel Replay + Adaptive sync Jouni Högander
2025-05-02  8:58 ` [PATCH 01/11] drm/dp: Add Panel Replay capability bits from DP2.1 specification Jouni Högander
2025-05-02  9:19   ` Jani Nikula
2025-05-02  9:28     ` Hogander, Jouni
2025-05-20  8:36   ` Nautiyal, Ankit K [this message]
2025-05-20 16:53     ` Hogander, Jouni
2025-05-02  8:58 ` [PATCH 02/11] drm/i915/psr: Read both Panel Replay capability registers from DPCD Jouni Högander
2025-05-20  8:45   ` Nautiyal, Ankit K
2025-05-20 16:54     ` Hogander, Jouni
2025-05-02  8:58 ` [PATCH 03/11] drm/i915/alpm: Add PR_ALPM_CTL register definitions Jouni Högander
2025-05-20  8:46   ` Nautiyal, Ankit K
2025-05-02  8:58 ` [PATCH 04/11] drm/i915/alpm: Write PR_ALPM_CTL register Jouni Högander
2025-05-20  8:49   ` Nautiyal, Ankit K
2025-05-20 16:55     ` Hogander, Jouni
2025-05-02  8:58 ` [PATCH 05/11] drm/i915/psr: Add interface to check if AUXLess ALPM is needed by PSR Jouni Högander
2025-05-20  8:52   ` Nautiyal, Ankit K
2025-05-20  9:19     ` Nautiyal, Ankit K
2025-05-20 16:56     ` Hogander, Jouni
2025-05-02  8:58 ` [PATCH 06/11] drm/i915/alpm: Add new interface to check if AUXLess ALPM is used Jouni Högander
2025-05-20  8:54   ` Nautiyal, Ankit K
2025-05-20 16:57     ` Hogander, Jouni
2025-05-02  8:58 ` [PATCH 07/11] drm/i915/alpm: Move port alpm configuration Jouni Högander
2025-05-20  9:00   ` Nautiyal, Ankit K
2025-05-20 16:59     ` Hogander, Jouni
2025-05-02  8:58 ` [PATCH 08/11] drm/i915/display: Add PHY_CMN1_CONTROL register definitions Jouni Högander
2025-05-20  9:01   ` Nautiyal, Ankit K
2025-05-02  8:59 ` [PATCH 09/11] drm/i915/display: Add function to configure LFPS sending Jouni Högander
2025-05-20  9:08   ` Nautiyal, Ankit K
2025-05-20 17:01     ` Hogander, Jouni
2025-05-02  8:59 ` [PATCH 10/11] drm/i915/psr: Fix using wrong mask in REG_FIELD_PREP Jouni Högander
2025-05-20  9:09   ` Nautiyal, Ankit K
2025-05-02  8:59 ` [PATCH 11/11] drm/i915/psr: Do not disable Panel Replay in case VRR is enabled Jouni Högander
2025-05-20  9:13   ` Nautiyal, Ankit K
2025-05-02 13:08 ` ✗ Fi.CI.CHECKPATCH: warning for Panel Replay + Adaptive sync Patchwork
2025-05-02 13:08 ` ✗ Fi.CI.SPARSE: " Patchwork
2025-05-02 13:30 ` ✓ i915.CI.BAT: success " Patchwork
2025-05-02 18:19 ` ✗ i915.CI.Full: failure " Patchwork

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8af5523e-1732-4e53-86c4-36fb1465d585@intel.com \
    --to=ankit.k.nautiyal@intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=intel-xe@lists.freedesktop.org \
    --cc=jouni.hogander@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox