From: Kieran Bingham <kieran.bingham@ideasonboard.com>
To: Daniel Oakley <daniel.oakley@ideasonboard.com>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Shuah Khan <skhan@linuxfoundation.org>,
linux-media@vger.kernel.org
Subject: Re: [PATCH 1/3] media: vimc: expand the names of vimc entity types
Date: Fri, 17 Jun 2022 08:05:48 +0100 [thread overview]
Message-ID: <165544954869.2786155.786044635537343355@Monstersaurus> (raw)
In-Reply-To: <9ea3155a-5099-e02d-3707-06b89395f8d1@linuxfoundation.org>
Quoting Shuah Khan (2022-06-16 22:57:36)
> On 6/16/22 3:24 PM, Kieran Bingham wrote:
> > Quoting Shuah Khan (2022-06-16 15:41:45)
> >> On 6/16/22 8:29 AM, Shuah Khan wrote:
> >>> On 6/16/22 4:07 AM, Daniel Oakley wrote:
> >>>> When introducing the lens controller, it became apparent that the vimc
> >>>> entity type names were hard to understand, e.g. vimc_len_type refers to the
> >>>> lens. The names of the vimc entity types have been expanded to make the
> >>>> code easier to understand. There is no functional change intended.
> >>>>
> >>>> Suggested-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
> >>>> Signed-off-by: Daniel Oakley <daniel.oakley@ideasonboard.com>
> >>>> ---
> >>>> .../media/test-drivers/vimc/vimc-capture.c | 270 ++++++------
> >>>> drivers/media/test-drivers/vimc/vimc-common.h | 10 +-
> >>>> drivers/media/test-drivers/vimc/vimc-core.c | 22 +-
> >>>> .../media/test-drivers/vimc/vimc-debayer.c | 393 +++++++++---------
> >>>> drivers/media/test-drivers/vimc/vimc-lens.c | 82 ++--
> >>>> drivers/media/test-drivers/vimc/vimc-scaler.c | 216 +++++-----
> >>>> drivers/media/test-drivers/vimc/vimc-sensor.c | 307 +++++++-------
> >>>> 7 files changed, 652 insertions(+), 648 deletions(-)
> >>>>
> >>>
> >>> Thank you for the patch to improve code readability. Looks good to me.
> >>>
> >>> Reviewed-by: Shuah Khan <skhan@linuxfoundation.org>
> >>>
> >>
> >>
> >> Reviewed all three patches
> >>
> >> Mauro,
> >>
> >> Would you like me to send a pull request for these patches?
> >
> > Hi Shuah,
> >
> > Please note that I believe these patches are based on top of Yunke's not
> > yet accepted patches for the vimc-lens.
> >
>
> Yes. I am aware of that. I will make sure they are applied in the right
> order.
>
Aha, perfect, thanks - I had missed that you had already reviewed
Yunke's patches before this.
--
Kieran
> thanks,
> -- Shuah
>
next prev parent reply other threads:[~2022-06-17 7:05 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-06-16 10:07 [PATCH 0/3] Vimc code readability improvements Daniel Oakley
2022-06-16 10:07 ` [PATCH 1/3] media: vimc: expand the names of vimc entity types Daniel Oakley
2022-06-16 14:29 ` Shuah Khan
2022-06-16 14:41 ` Shuah Khan
2022-06-16 21:24 ` Kieran Bingham
2022-06-16 21:57 ` Shuah Khan
2022-06-17 7:05 ` Kieran Bingham [this message]
2022-06-16 10:07 ` [PATCH 2/3] media: vimc: enumerate data link entities for clarity Daniel Oakley
2022-06-16 14:30 ` Shuah Khan
2022-06-16 10:07 ` [PATCH 3/3] media: vimc: use data link entities enum to index the ent_config array Daniel Oakley
2022-06-16 14:31 ` Shuah Khan
2022-06-28 20:05 ` Shuah Khan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=165544954869.2786155.786044635537343355@Monstersaurus \
--to=kieran.bingham@ideasonboard.com \
--cc=daniel.oakley@ideasonboard.com \
--cc=linux-media@vger.kernel.org \
--cc=mchehab@kernel.org \
--cc=skhan@linuxfoundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox